Foros Simulación Plugins rFactor2 Mapas circuitos para rFactor 2 Respuesta a: Mapas circuitos para rFactor 2

#6213
Sauron
Organización
Up
0
Down

Bueno, ya por fin he conseguido que me funcione, así que paso a relatar los problemas que me he encntrado y como los he ido solucionando. El cómo hacer cada paso es sencillo, usual o lo pone por internet, así que no lo explicaré para no extender esto con explicaciones aparte.

Partimos de rF2 y sistema operativo Windows7. La intención es ver el Dashboard en la pantalla del PC, con el rF2 tal y como teníamos el GID.
– Lo primero es que al instalar me pide una versión de NET Framework que no tenía. Sino ni se instala.
Descargo la versión de NET Framework (exactamente la que pide, pues hay posteriores pero de momento no me hacen falta).
– Al instalar la versión requerida me dice que no puede ser pues o bien el sistema operativo no vale o le falta como mínimo el ServiPack1
Me descargo he instalo el SP1 para Windows7
Instalo el NET Framework
Instalo el SimHub, los dos archivos que se mencionan por ahí arriba. Lo configuro, selecciono el Layout, lo grabo, … todo como pone por ahí arriba.
– No se ve el Simhub en el juego.
Tras trastear por las instrucciones pone que:
– En video settings de rF2
Mode = Borderless
VSYNC = on (no sé si es Sync=Software)
En la ventana azul que sale del Symhub, cuando ya ha cargado el layout elegido, la casilla de “Hide when not in race” la dejo MARCADA.

– Con esto ya me aparece todo el layout elegido en el juego, pero no actualiza datos. Están todos los tiempos y valores a 0. Enla parte de “Games” del SIMHUB, al seleccionar el rF2 hay un “open instructions” donde pone:
Place the rFactor2SharedMemoryMapPlugin64.dll inside Bin64\plugins folder of your Rf2 installation
Busco ese archivo “rFactor2SharedMemoryMapPlugin64.dll” en las carpetas de SIMHUB, lo coloco donde indica “Bin64\plugins” de rFactor2 (es normal que faltara pues es la manera que el rF2 manda datos al SIMHUB) pero sigue sin actualizar.

– De ésta última parte no puedo confirmar donde está pero sí que es necesaria por lo visto. LA cuestión es que al haberla ejecutado por lo visto ya no me sale, y no estoy seguro donde lo vi, pero por lógica:
En la parte de GAMES del SIMHUB debe haber dos “botones” azules arriba a la derecha, uno que es para realziar una acción de forma AUTOMÁTICA y otro que es para hacer lo mismo de forma MANUAL. Al darle al MANUAL sale la carpeta donde está el archivo dll de “comunicación” entre el rF2 y el SIMHUB, pero como yo ya lo había copiado, ciero y elijo la forma AUTOMÁTICA.
Al ejecutarla me sale un mensaje tipo “Ahora tienes el SIMHUB correctamente instalado y puedes disfrutar de el en tu simulador” o algo así. A partir de ahí sin problemas.
Nota: repito que no recuerto la ubicación de esta última opción, si no es en GAMES estará por ahí, pero está y hay que darle. Al menos en mi caso.