Foros Foros de Ayuda Ayuda rFactor 2 Problemas de rendimiento, bajos FPS, pantallazos y congelaciones en rFactor2

  • Creador
    Debate
  • #10413
    JParra
    Organización

    Visto que desde que abandonamos la build 1114 de rfactor 2 los problemas que en ese día surgieron siguen dando problemas a los pilotos, muchos de ellos compartidos entre varios, y ya que, al menos en esta v1117 no hay indicios de que se solucionen por parte de S397, abro debate para intentar localizar y solucionar al menos aquellos que si puedan tener una solución.

    Este debate es para participar todos con nuestro granito de arena, ya que estoy seguro que más de uno tiene tantas o más publicaciones leídas en Internet que yo.

    Pero para ahorrar tiempo y preguntas siempre obvias, tendremos una metodología fija en cada uno de los problemas. Esto no es más que, al mismo tiempo que se publica una respuesta con el problema, se dejen algunos datos tanto del equipo como del entorno en el que se hacen las pruebas (online- offline, DX11 o DX10, versión, plugins, etc…)

    Os dejo estas puntos básicos con ejemplos para que copiéis y peguéis en vuestra respuesta.

    • Equipo: Windows 10 Pro – CPU: i7 – RAM: 16 GB – GPU: GTX 1080 – VR: Oculus Rift
    • Problema en: Online y Offline
    • DirectX: 11
    • rF2 Build: 1117
    • Otros plugins instalados: HUD para VR e Idioma Español.

    Es conveniente que publiquéis las pruebas que habéis hecho, para evitar que os den consejos que ya habéis probado.

    IMPORTANTE: Aunque muchas veces desaconsejamos el uso de respuestas anidadas porque se confunden en la línea de tiempo, en este caso es muy recomendable por si existen varios temas en marcha, que se sepa concretamente a que problema se esta respondiendo. Esto se hace de una forma muy sencilla, haciendo clic en el enlace “Responder” en la cabecera del mensaje.

    Error al mostrar la imagen de drive

    Por ultimo os dejo con algunas de las pruebas que son básicas para todos los problemas y que es conveniente que las realicéis y pongáis el resultado al publicar vuestro problema, porque ahorrará tiempo y respuestas obvias además de acotar mucho el problema.

    Pruebas Básicas para descartar causas.

    1. Desactiva todos los añadidos que tengas antes de hacer las pruebas (Idioma español, HUD, Spotter, mapas…)
    2. ¿El problema se reproduce online y offline o solo en uno de los modos?
    3. Si usas VR ¿Te ocurre tanto en VR como con el monitor?
    4. Prueba tanto en DX11 como en DX9 (En Steam -> Biblioteca -> rFactor 2 -> Clic derecho “propiedades” -> Pestaña BETAS ->Desplegar y elegir versión que sea DX9)

    Problemas conocidos

    A continuación, crearé y entre todos mantendremos una lista de problemas conocidos, por si alguien llega aquí con ese problema, que lo pueda solucionar sin tener que publicar respuesta.

    • Se conocen problemas relacionados con los replays, que se solucionan desactivando las repeticiones.
    • Se conocen problemas con algunas versiones del plugin en español. Probad a quitarlo.
    • Congelación a los 30 minutos de estar en pista. Desde que cambiamos de versión dejando atrás la 1114 varios usuarios reportaron que las congelaciones se producían alrededor de los 30 minutos en pista. Una forma de solucionarlo es entrar al server y dejar el coche en pista 30 minutos antes de la sesión oficial.
Mostrando 10 respuestas a los debates
  • Autor
    Respuestas
    • #10414
      JParra
      Organización
      Up
      0
      Down

      La gente que tiene problemas con la congelación de pantalla a los 30 minutos de estar en pista (la vamos a llamar así para generalizar) ¿Les pasa también offline?
      Lo digo para que hagan ellos el cambio a la 1114 y que prueben a ver si se soluciona, ya que es muy sencillo de realizar en los clientes y más complicado en los servidores.

      Si la mayoría soluciona el problema cambiando a v1114, cambiamos los servidores hasta que saquen una nueva build (la 1118 supongo) y prueben si se les ha solucionado el problema.

    • #10438
      JMartinez
      Piloto
      Up
      0
      Down

      Como la gran mayoria ya sabreis yo soy uno de los que sufren las congelaciones de imagen, no fisicas, lo que quiere decir que se congela la imagen pero en segundo plano las fisicas del juego siguen ejecutandose, y cuando se descongela la imagen te encuentras contra un muro o enmedio del cesped, a todo esto las funciones del volante y los pedales funcionan perfectamente, solo se congela la imagen, esto es lo que me pasa a mi. Esto suele pasarme durante los 30/40 primeros minutos de sesion del juego, ojo tienes que estar en pista, lo de sestar dentro y no rodar no cuenta, despues ya no se vuelve a repetir. Se volveria a repetir, en off line si le das a la pestaña de abandonar sesion, en online si le das en la pestaña de abandonar sesion, si tienes un conction lost o si el servidor te hecha fuera, por cambios de sesion de practica a clasificacion o a carrera no se repite.

      Lo primero que hice fue empezar a quitar cosas que se estuvieran ejecudando en segundo plano en el pc, por si era alguna aplicacion que saltaba y me lo provocaba, llegue a quitar el esplorer el  correo y hasta el antivirus a ultima hora y seguia igual. Desinstale por completo rF borre carpeta rF, hice una instalacion limpia sin plugins, incluso los que vienen los deshabilite, con todo y eso seguia igual. Ahi es cuando entre al foro de studio 397 y vi que no era el unico que tenia esos ploblemas, en el me sugirieron que habilitara un sistema de logs que tiene rF y que les hiciera llegar los Logs y el video con las congelaciones, pues eso hice como mucha mas gente hizo , y saben que? que nos quedemos igual por no nos hicieron ni puñetero caso. La unica solucion que he encontrado ¨que no es solucion¨es entrar con antelacion de una hora o mas para poder tener el coche en pista por lo menos 40 minutos y tener esa congelacion antes de pasar a carrera. Ahora probare a bajar de build a la 1114, que ya estuve tentado pero con esa version no podia correr, pruebo la 1114 y ya os comento.

       

    • #10439
      Delaosa
      Moderador
      Up
      0
      Down

      Me acaba de pasar, y si, entre 30 y 40 minutos rodando, entre entradas a box a cambiar algun parametro y salir.

       

      Es como dice JMartinez, el juego sigue pero no lo ves

      • #10446
        JParra
        Organización
        Up
        0
        Down

        Sería un aporte increíble que pudieras probar en la 1114 y comentar los resultados.

      • #10448
        JParra
        Organización
        Up
        0
        Down

        ¿Puedes pegar aquí o adjuntar ese log?

        • #10451
          JMartinez
          Piloto
          Up
          0
          Down

          Por defecto rf ya crea un log , pero con pocos datos, para que registre todos los datos que pide S397 hay que cambiar un dato en nuestro archivo player.json, la linea RealTimeLogging hay que ponerle el valor en 1. Si no teneis problemas no lo hagais , pues es un recurso que consume CPU para crear el log. Los archivos creados se guardan en nuestra carpeta de rf en UserData – Log

    • #10450
      Tuercas
      Piloto
      Up
      0
      Down

      mi problema es diferente

      en ocasiones me pasa al poco de entrar otras veces me pasa al rato de estar dentro(no a la media

      hora),la ultima en los entrenamientos del GT-R entre a las 22:30 y a las 22:40 se congelo, pero a mi

      se congela 25 segundos seguidos se queda el coche tal como esta de gas y giro desaparezco para los demas

      y aparezco en el mismo sitio

      • #10452
        JMartinez
        Piloto
        Up
        0
        Down

        En el foro de Studio 397 hay varios tipo de congelaciones que estan ocurriendo ultimamente y no son todas iguales, pero la gran mayoria coinciden en que ocurren entre los primeo 40 minutos de juego, cosa que tu tambien comentas. Tu podrias probar a vaciar la carpeta de replays

    • #10457
      JParra
      Organización
      Up
      0
      Down

      Repito que sería muy interesante que alguno de los que tenéis problemas os cambiarais a la versión 1114 y probarais, porque si así la mayoría resuelve sus problemas, nos plantearemos retroceder el servidor hasta que salga una nueva versión 1118.

      Os dejo enlace a como se hace: https://www.racingonlineclub.com/volver-a-una-version-anterior-de-rfactor-2/

      • #10465
        JMartinez
        Piloto
        Up
        0
        Down

        Probado con la built 1114, y me pasa lo mismo, minuto 34 congelacion de imagen. Si en el foro de studio397 no se comenta nada de cambiar de built sera por que ya lo probaron pero bueno prueba hecha, regreso a la 1117 y desconectare toda grabacion de replay y volvere a probar

        • #10556
          JParra
          Organización
          Up
          0
          Down

          Disculpa Martinez se me habia perdido esta respuesta. Pues queda descartado volver a la 1114. Gracias

    • #10460
      JParra
      Organización
      Up
      0
      Down

      Ayer me pasó una cosa en otro juego y recordé el tema de que había gente que inexplicablemente le “rateaba” la imagen aún teniendo un buen maquinon.

      EL caso es que, a parte de los replays del propio rFactor 2 (que como indico en el anuncio de este debate aconsejamos deshabilitar para depurar errores) hay otros sistemas que se dedican a guardar un replay de nuestro juego, y eso a veces por cuestiones de permisos o de espacio en disco no pueden hacerlo y producen esos “rateos” de FPS como si condujeras un patinete por una pista de grava.

      Por tanto, recomiendo revisar y aún mejor desactivar los sistemas de guardado de replays para ver si el problema te lo está generando ese software que nada tiene que ver con rFactor 2.

      Estos sistemas son:

      • Nvidia Geforce Experience. Solo para gráficas Nvidia, se acede a la configuración desde el área de notificación, clic derecho en el icono de Nvidia y elegir “Nvidia Geforce Experience”. En la app que se abre ir a “General” y “Superposición dentro del juego” para poder configurarlo o desactivarlo.
      • XBox Game Bar. Metido por narices en Windows 10 recientemente desde su Update, se accede a la configuración con la combinación de teclas [WINDOWS + G] Luego vais a la rudeda dentada para sacar la configuración y os desplazais a “Capturando” donde podréis deshabilitar la “captura mientras juego”.
      • El propio replay del rFactor 2.

      Tened en cuenta que hasta con buen equipo y espacio en disco, a veces una configuración de nada (por ejemplo tener como destino una carpeta que necesite permisos especiales) estos software pueden estar creando retardos en lecturas y demás por estar intentando hacer una tarea que no pueden.

    • #10470
      Delaosa
      Moderador
      Up
      0
      Down

      Yo tengo desactivado el guardado de replays hace años, pero si que tengo bastantes repeticiones guardadas (no se si eso afectará en algo, es una carpeta como otra). Las borraré también.

      Lo de geforce experience si lo tengo quitado, y lo de xbox bar diria que no. Mañana revisare todo, porque me ha pasado 1 sola vez que me haya dado cuenta, pero falta que te estés disputando algo para que pase mas seguido.

      Dentro de lo malo, lo bueno es que como el coche sigue, salvo que estes en una frenada fuerte, puedes intuir por donde va a ir el coche y seguir, sin perder demasiado tiempo. Lo de Tuercas es otro rollo…

    • #10495
      farfex
      Piloto
      Up
      0
      Down

      Desactivé el Replay de xbox y se volvió a congelar sobre la media hora. Así que no creo que el problema sea de eso.

    • #10504
      Rodenas777
      Piloto
      Up
      0
      Down

      bueno yo decididamente creo que ya lo e provado todo… con 1 monitor, con 2, con 3 y son ningnno con las gafas. a tope de graficos, al minimo de graficos… con todos los programas externos ( desde el amintrados de tareas) cerrados aprocandole todos los recursos de mi pc que creo que no son pocos, y sigue pegandome los enganchones dichosos, anoche un poco fustrado y con poco sueño saque ganas de donde no habia y me puse a repetir muchas de las pruevas que ya ice, y buscando si me habia dejado algo por desactivar (del tema repeticiones) y prove otra vez con el monitor con las vr desactivadas, y con mas de 200 FPS constantes en todo el circuito, hay 3 sitios del circuito donde me pega esos tirones dichosos, que si ya son molestos con el monitor con las vr ya ni te cuento.

      tambien e descubierto que es una cosa que se agraba contra mas vueltas  e dado/gente en pista. yo solo espero ansiono la proxima actualizacion de RF2 pera poder volver a pista en condiciones. 1 saludo y gracias por vuestra ayuda

      • #10505
        farfex
        Piloto
        Up
        0
        Down

        Vaya pena, Rodenas… Imagino que habras desinstalado y reinstalado… Otra cosa que se me ocurre es que cambies configuracion de Video Settings en el launcher si no lo has hecho, o que no instales rFactor en la carpeta “Archivos de Programa”

    • #10510
      JParra
      Organización
      Up
      0
      Down

      ¿Alguien ha probado ya a volver a la versión 1114?

      Es una versión donde nadie tenia problemas y si confirmáis que estos también se van de forma general, el server se cambiará a una versión anterior para que todos podamos disfrutar. Personalmente me da igual la versión, por vieja que sea, si eso permite a todos disfrutar.

      Como los problemas según Martinez también son en offline, es muy sencillo de probar. Vas a Steam, retrocedes la versión, esperas a que se actualice y pruebas alguna combinación que te diera problemas con la v-1117.

      Sin las pruebas confirmadas de varios de vosotros, no vamos a retroceder el servidor, primera porque cuesta mucho más que las instalaciones cliente de todos, y porque no vamos a mover a 15 o 20 pilotos sin tener las pruebas definitivas.

      Mientras como dice Rodenas esperamos una nueva actualización que lo solucione, estoy viendo por vuestras pruebas que es el único camino que nos queda por probar.

      Os dejo enlace al procedimiento de volver atrás una versión de rFactor 2.

      https://www.racingonlineclub.com/volver-a-una-version-anterior-de-rfactor-2/

      • #10511
        JMartinez
        Piloto
        Up
        0
        Down

        Parra yo ya baje a la 1114 y respondi mas arriba, parece ser que no lo viste la respuesta que esta unos cuantos mensajes mas arriba

         

    • #10513
      JMartinez
      Piloto
      Up
      0
      Down

      Otra cosa, yo ya desinstale  Nvidia Geforce Experience por que lei que podia causar problemas, por lo tanto no tengo grabaciones de replay por ahi. XBox Game Bar tambien ya lo tenia configurada para que no grabara replays, solo me quedaria deshabilitar el replay de rf, pero ya estoy viendo que muchos de vosotros lo teneis deshabilitado y el ploblema sigue estando. Esperar a la 1118

Mostrando 10 respuestas a los debates
  • Debes estar registrado para responder a este debate.